Worst piece of audio equipment ever used - Page 3 - Realm of Excursion



Product Reviews Post a reviews for a product you have owned/used.

Reply
Old 12-11-2009   #51 (permalink)
120 dB
 
Join Date: Jan 2009
Location: Burleson,TX
Posts: 28
Rep Power: 149
tater6061 is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

LOADMASTER I mean Roadmaster 4's.I got them from a friend.
tater6061 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-24-2009   #52 (permalink)
140 dB
 
Join Date: Sep 2007
Age: 32
Posts: 981
Rep Power: 203
sound=vibration is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

My worst piece of audio equiptment i owned was an Xblod yes Xblod amp i bought when I first got into audio and let me tell you if you think xplod is bad you havent seen nothing I gave it away lol
__________________
NEW CAR IN THE WORKS.. POWERED BY SSA
sound=vibration is offline   Reply With Quote Quick reply to this message
Old 12-27-2009   #53 (permalink)
150 dB
 
creyc's Avatar
 
Join Date: Oct 2006
Age: 33
Posts: 2,056
Rep Power: 261
creyc has a solid reputation - Well liked by the forum memberscreyc has a solid reputation - Well liked by the forum memberscreyc has a solid reputation - Well liked by the forum members
Default Re: Worst piece of audio equipment ever used

Worst piece of equipment owned:

__________________
2001 Blazer, 2nd row wall:
(2) 18" Fi BLs
(2) SAZ-3000Ds
creyc is offline   Reply With Quote Quick reply to this message
 
Old 12-27-2009   #54 (permalink)
150 dB
 
Join Date: Mar 2008
Location: Lafayette, LA
Age: 37
Posts: 1,400
Rep Power: 0
Beatdown337 has a solid reputation - Well liked by the forum membersBeatdown337 has a solid reputation - Well liked by the forum membersBeatdown337 has a solid reputation - Well liked by the forum members
Default Re: Worst piece of audio equipment ever used

gotta love the craftsmanship
Beatdown337 is offline   Reply With Quote Quick reply to this message
Old 01-02-2010   #55 (permalink)
120 dB
 
Join Date: Jan 2010
Location: 804 - Va
Posts: 34
Rep Power: 137
LETNOFF is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

AudioBahn A8000T worst amp ever
LETNOFF is offline   Reply With Quote Quick reply to this message
Old 01-02-2010   #56 (permalink)
130 dB
 
Join Date: Aug 2009
Location: Jackson, TN
Age: 42
Posts: 292
Rep Power: 152
ZeusVI is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

punch 150a2. Total $h!t Box. It actually ties with the old Rockwod 75x2- the old brown ones with the flip-up plate to adjust gains....I think they both put out the same rms, which is a joke. Ihad bothanswapped them back and forth a few times. Total suck.

Fury amps....You will be Furious. Rampage amps...you will go on a rampage...
__________________
Nice paintjob......Wanna race?
ZeusVI is offline   Reply With Quote Quick reply to this message
Old 01-15-2010   #57 (permalink)
150 dB
 
Boosted77's Avatar
 
Join Date: Dec 2009
Location: Lawrenceville, Ga.
Posts: 1,964
Rep Power: 279
Boosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossible
Default Re: Worst piece of audio equipment ever used

My "new" Hifonics ZXi1008. It's not like it was a piece, but it was defective out of the box.

Also some subs I got from Walmart. I can't remember the brand, but they had a butyl rubber surround and a nice looking aluminum basket. I blew 2 of them in 2 days in a sealed encloser running a "TIS1802" CES rated at 220 watts rms x 2. That little amp would get off. I just found a like new Zapco Ref750 amp at a pawn shop for $150 bucks, so I traded the TIS in as a down payment for the Zapco. I only payed $30 bucks for the TIS and they gave me $30 for it so I didn't loose anything.
Boosted77 is offline   Reply With Quote Quick reply to this message
Old 01-16-2010   #58 (permalink)
150 dB
 
Boosted77's Avatar
 
Join Date: Dec 2009
Location: Lawrenceville, Ga.
Posts: 1,964
Rep Power: 279
Boosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossibleBoosted77 has the highest rating we can give - To make it this far is  nearly impossible
Default Re: Worst piece of audio equipment ever used

Oh yeah, I forgot. I bought a brand new MA audio HK802 from Ebay. Took it out of the box, hooked it up and it was also defective! If I turned it up at all, the voltage would drop down below 9 Volts! So I hooked back up my old amp, problem disappears and the bass is back. Sent the amp back, they call me and say there is nothing wrong with it. Yeah right. Stop lying.
Boosted77 is offline   Reply With Quote Quick reply to this message
Old 01-17-2010   #59 (permalink)
Mat
130 dB
 
Mat's Avatar
 
Join Date: Nov 2007
Location: Fargo, ND
Age: 30
Posts: 204
Rep Power: 170
Mat is still in the green - This is good
Default Re: Worst piece of audio equipment ever used


blew those in literally like a month, then got new ones from the company under warranted for 30 bucks, and blew those in a month.

then i learned about this thing called "real Car audio" and have never gone back. i was maybe 13-14 at the time.


next worse one was a prefab 6x9 box, that actually looks really nice, but a friggin tang band 6x9 CONSTANTLY blows out the terminal cup in the back... WTF! those arent even loud

and then a Marshal 30 watt guitar amp i bought when i was younger... biggest piece of crap guitar equip ive ever owned, although im sure it was just a melon cause Marshal pretty much rules the world.
__________________
Summer driver-2002 M6 WS6 Trans Am
SQ setup, 10 speakers, 10" Type X sealed @ 1kw

Winter Beater 4x4-1997 Oldsmobile Bravada
18" Fi BL @1kw, [email protected]
Mat is offline   Reply With Quote Quick reply to this message
Old 01-17-2010   #60 (permalink)
130 dB
 
Mugwomp's Avatar
 
Join Date: May 2009
Location: Tyler, TX
Posts: 249
Rep Power: 162
Mugwomp has a awesome reputation - Members love this one!Mugwomp has a awesome reputation - Members love this one!Mugwomp has a awesome reputation - Members love this one!Mugwomp has a awesome reputation - Members love this one!Mugwomp has a awesome reputation - Members love this one!Mugwomp has a awesome reputation - Members love this one!
Default Re: Worst piece of audio equipment ever used

Anything Roadmaster, I've fried my amp over that POS.
__________________
"Nah man, never use 0awg wire for power, always go with AT LEAST 24awg!"
Dr. Subwoofer is a known terrorist and will blow up more than your box.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mugwomp is offline   Reply With Quote Quick reply to this message
Old 01-17-2010   #61 (permalink)
130 dB
 
DD9915D!!!'s Avatar
 
Join Date: Aug 2009
Posts: 252
Rep Power: 151
DD9915D!!! is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

Legacy 2 way powered x/o. <----- NOISE MAGNET! LOL!
__________________
Refs: DrBass
DD9915D!!! is offline   Reply With Quote Quick reply to this message
Old 01-17-2010   #62 (permalink)
0 dB
 
Join Date: Mar 2008
Age: 48
Posts: 9
Rep Power: 0
GlasSman is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

Pyramid "100 X 2" amp.

Luckily by buddy wanted blow it up so bad he traded me an Alpine 2 channel amp for it.

The Alpine still works fine.....the Pyramid has been dead now for a loooong time.
__________________
////Alpine/MB Quart/Image Dynamics/Soundstream
GlasSman is offline   Reply With Quote Quick reply to this message
Old 02-06-2010   #63 (permalink)
160 dB
 
Saynkuck123's Avatar
 
Join Date: Jan 2006
Posts: 2,742
Rep Power: 294
Saynkuck123 is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

Quote:
Originally Posted by Beatdown337 View Post
I know alot of you guys have horror stories about that amp, sub, or cd player that just wasnt worth a f*** whether it was a name brand or not. For me it was this rockford fosgate (single din) cd player that i bought back in like 02'. The sound quality was terrible, there was hardly any tunability and to top it off the preout voltage was under a 2. I changed to it from an entry level alpine that i had gotten at circuit city and the alpine sounded wayyyyy better. from the first second i knew i was f*****. lol
Actually it was a Denon deck. Rockford doesn’t make decks. They bought Denon decks and printed their name on it.
Saynkuck123 is offline   Reply With Quote Quick reply to this message
Old 02-09-2010   #64 (permalink)
120 dB
 
Join Date: Oct 2008
Age: 40
Posts: 55
Rep Power: 152
ceh478 is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

jensen, audiobahn, dual,,,,all crap
ceh478 is offline   Reply With Quote Quick reply to this message
Old 02-17-2010   #65 (permalink)
120 dB
 
fastlife's Avatar
 
Join Date: Jan 2010
Location: chicago
Age: 32
Posts: 49
Rep Power: 136
fastlife is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

wal-mart virtual reality labs vr3 2-channel amplifier. roadmaster dual 6 1/2" speaker box w/ tweeters. dual xs series subs from pep boys. " red shiny ones" also all the digital audio stuff from pepboys. all of this was a biiig waste of my time a loong time ago.
__________________
*Evil Eg*

*now* 3 12" kicker cvr's in a vented box. 1.75 cubes per sub, tuned to 33hz. Soon to have all 6 back in. In a wall type setup.*

*Last setup* Orion Hcca 15.2 bxi2608d at 1-ohm.

*Setup before the hcca*146.8 2 15" cvr's bxi1610d .5 ohms
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
fastlife is offline   Reply With Quote Quick reply to this message
Old 02-17-2010   #66 (permalink)
130 dB
 
DD9915D!!!'s Avatar
 
Join Date: Aug 2009
Posts: 252
Rep Power: 151
DD9915D!!! is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

I got a legacy/pyramid electronic cross over, I ran it to a USA-50 for a subwoofer.

My shop-vac sucking up nails is less noisy...
__________________
Refs: DrBass
DD9915D!!! is offline   Reply With Quote Quick reply to this message
Old 02-17-2010   #67 (permalink)
130 dB
 
Join Date: Jan 2007
Location: minnesota
Age: 48
Posts: 299
Rep Power: 202
weshole has the second highest rating possible - An extreme assest to the forum!weshole has the second highest rating possible - An extreme assest to the forum!weshole has the second highest rating possible - An extreme assest to the forum!weshole has the second highest rating possible - An extreme assest to the forum!weshole has the second highest rating possible - An extreme assest to the forum!weshole has the second highest rating possible - An extreme assest to the forum!weshole has the second highest rating possible - An extreme assest to the forum!weshole has the second highest rating possible - An extreme assest to the forum!
Default Re: Worst piece of audio equipment ever used

I had a PG knock off "Thump Gold" amp bitd. WOW!!! what a pos. It even looked like a PG M50.
weshole is offline   Reply With Quote Quick reply to this message
Old 04-11-2010   #68 (permalink)
120 dB
 
Join Date: Apr 2010
Posts: 71
Rep Power: 135
-0nes- is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

i had a sick ass sony that lasted for 4 hrs before it killed my 6*9 roadmaster that i got at a yard sell what a rip
-0nes- is offline   Reply With Quote Quick reply to this message
Old 04-11-2010   #69 (permalink)
150 dB
 
creyc's Avatar
 
Join Date: Oct 2006
Age: 33
Posts: 2,056
Rep Power: 261
creyc has a solid reputation - Well liked by the forum memberscreyc has a solid reputation - Well liked by the forum memberscreyc has a solid reputation - Well liked by the forum members
Default Re: Worst piece of audio equipment ever used

An SPL meter.




Ruining my life! lol
__________________
2001 Blazer, 2nd row wall:
(2) 18" Fi BLs
(2) SAZ-3000Ds
creyc is offline   Reply With Quote Quick reply to this message
Old 04-11-2010   #70 (permalink)
150 dB
 
03protege's Avatar
 
Join Date: Jan 2007
Location: Mandeville, La
Age: 32
Posts: 1,394
Rep Power: 227
03protege is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

Quote:
Originally Posted by Sayar Kuchenski View Post
Actually it was a Denon deck. Rockford doesn’t make decks. They bought Denon decks and printed their name on it.
Do you go upto every Cadillac, Lincoln, and Lexus owner and tell them they own a Chevy, ford, toyota with their name printed on it?

Now days its not uncommon for company's to have their goods produced by someone else.
__________________
Not enough time with to much to do!
03protege is offline   Reply With Quote Quick reply to this message
Old 04-13-2010   #71 (permalink)
0 dB
 
Join Date: Feb 2010
Location: Las Vegas
Posts: 15
Rep Power: 0
rockcity is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

I had a single Jensen 12 when I was in high school with a road gear amp I bought from a junk yard. It was the worst system I'd ever owned. I traded in the amp at WalMart for a JVC and the sub blew shortly after. The amp was only rated at like 250wrms. Definition of wack.
rockcity is offline   Reply With Quote Quick reply to this message
Old 04-29-2010   #72 (permalink)
130 dB
 
metaljoey's Avatar
 
Join Date: Jan 2010
Posts: 175
Rep Power: 142
metaljoey is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

i had a full out audiobahn system. i replaced 2 amps and 2 subs with in a year! ouch! lol in my face!!
metaljoey is offline   Reply With Quote Quick reply to this message
Old 05-04-2010   #73 (permalink)
120 dB
 
Join Date: May 2010
Posts: 59
Rep Power: 134
Evil Ryu is still in the green - This is good
Default Re: Worst piece of audio equipment ever used

sony headunits.

last one i had over 10 yrs ago u could turn the volume up, but not down LOL!
Evil Ryu is offline   Reply With Quote Quick reply to this message
Old 06-29-2010   #74 (permalink)
130 dB
 
thefowlerfam's Avatar
 
Join Date: Feb 2010
Location: Holiday, FL
Posts: 200
Rep Power: 145
thefowlerfam has a solid reputation - Well liked by the forum membersthefowlerfam has a solid reputation - Well liked by the forum members
Default Re: Worst piece of audio equipment ever used

Dual xdvd9101 1st thing was it quit playing cd's, played dvds fine. Then the screen would get stuck halfway out, had to lift it up for it to come out, then dvds quit playing and finally the touchscreen quit. Worst unit I ever owned, but their customer svc was great, sent it in and got a new one in less than 2 weeks. JL Audio took 4 months to get my old 500/1 back to me. I sold it as soon as I got it back though...
__________________
2008 Ford Escape Limited w/ 3.0L V6
H/U: Kenwood DDX319
Fronts: MB Quart PVL268
Rears: Stock
Sub: RE Audio SEx 12D2
Amps: MB Quart ONX2.100 & ONX1.1000D
Main wire: 20ft run of 0awg to a fused distribution block. Short runs of 4awg to amps. 3.5ft run of 0awg ground to distribution block w/ short runs of 4awg to amps. 200amp fuse by battery
. In the distribution block, 1-100amp & 1-50amp fuse to amps.
thefowlerfam is offline   Reply With Quote Quick reply to this message
Old 06-30-2010   #75 (permalink)
0 dB
 
Hamsandwich's Avatar
 
Join Date: Jun 2010
Location: Kansas
Posts: 13
Rep Power: 0
Hamsandwich is in the red -  Must have upset some poeple...
Default Re: Worst piece of audio equipment ever used

I read this thread and see a lot of equipment that I have had success with in the past. Installing at various shops over the years, I had the opportunity to install tons of bunk gear. I always tried to give the customer their money's worth. Sometimes, the results are amazing with crap equipment and solid install.

That being said the worst audio equipment I have worked with were the entry-level powerbase (before they changed the spelling) around 2004 - 2005. I don't think I saw one last more than a week without a smoking the coil.

Rockwood, Kingwood, Kenford, TNT, and all those flea market amps usually have a single chip for amplification. Usually, they are a downgrade from deck power.

I always had a bunch of issues with the old Orion DEQ - 30. IT was way too buggy for its price

-Chris
__________________
Crimpin aint easy!
Hamsandwich is offline   Reply With Quote Quick reply to this message

Reply

  Realm of Excursion » Member Contributions » Product Reviews

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Realm of Excursion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Amps
A/d/s/
Advent
Alphasonik
Alpine
American Bass
ARC Audio
Atomic
Audio Art
Audio Gods
Audiobahn
Audiocontrol
Audiopipe
Audison
Aura
Autotek
Avionixx
Bazooka
Beyma
Blaupunkt
Boss
Boston Acoustics
Bravox
Cadence
Cascade (CAE)
CDT Audio
Cerwin Vega
Clarion
Clif Designs
Concept
Coustic
Critical Mass
Crossfire
Crunch
DB Drive
DC Audio
DC Power
DEI
Denon
Diabolo
Diamond
Digital Designs
Directed
DLS
Dual
DYnamat
Dynaudio
Earthquake
Eclipse
Elemental Designs
ESX
Eton
Farenheit
Fi Car Audio
Focal
Fusion
Genesis
Ground Zero
Hafler
Helix
Hertz
Hifonics
Hushmat
Image Dynamics
Infinity
Interfire
JBL
Jensen
JL Audio
JVC
Kenwood
Kicker
Knu Konceptz
Kole Audio
Kove Audio
Lanzar
Lightning Audio
Linear Power
MA Audio
Magnat
Marantz
Massive Audio
MB Quart
McIntosh
Memphis
Metra
MMATS
Mobile Authority
Morel
MTX
Nakamichi
Niche Audio
O2 Audio
Ohio Generator
Optima
Orion
Oxygen Audio
OZ Audio
PG Audio
Phase Linear
Phoenix Gold
Pioneer
Polk
Power Acoustik
Powerbass
Powermaster
Precision Power
Profile
Pyle
Pyramid
RadioShack
Rainbow
Rampage
RE AUdio
Rockford Fosgate
Scanspeak
Scosche
Seas
Sony
soundstream
Sparkomatic
SPL Dynamics
Stinger
Sundown Audio
Swiss Audio
Targa
TC Sounds
TREO Engineering
TRU
Tsunami
Ultimate
US Acoustics
US Amps
Velodyne
Vifa
Viper
Visonik
Xtant
Zapco
Zed Audio
Powered by vBadvanced CMPS v3.2.3

Links
Buy car audio
buy & sell car audio stereo equipment. Purchase used amps, subs speakers for sale and buy classified listings for 12 volt amplifier and subwoofer sales forum
Car Audio Forum
Buy car audio, Sell mobile audio, Wholesale 12 volt, automotive community forum, sub sub woofer, speakers, amplifier, amps, car audio forum
DIYMA
diymobileaudio.com is the DIY car audio install forum for automotive quality and spl stereo bass. 12 volt audio installation wholesalers buy amps, subs, double din car audio head unit electronics and ipod blue tooth car alarms at discounted prices
Sound Deadener
Sound deadening, vibration damper, cld tile, damping mat. Anti vibration pads for automotive insualtion damping, CDL mat, sound damping, noise killer, vibration damper sound deadener


All times are GMT -7. The time now is 04:57 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
ABMM Powered by Syrian Medical Society
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.